Strona główna forum
Forum
Elektryka, Elektronika, Audio & Video

[e39] 525d 2001 Webasto K-bus Breakdown

Elektryka w waszych piątkach czyli wszystko co dotyczy sprzętu grającego, alarmów, nawigacji, TV w samochodzie itp.
Tytan55

Posty: 17
Dołączył(a): 2011-01-25, 15:30
Lokalizacja: Gdynia

Moje BMW: E39 525d i 530da

[e39] 525d 2001 Webasto K-bus Breakdown

Postprzez Tytan55 » 2019-03-20, 10:44

Witam

Tematów wiele jest ale takiego jak mój problem nigdzie nie znalazłem

W skrócie piec przechodzi pełny cykl jako dogrzewacz jeśli auto pracuje i nie przerwie się jego pracy poprzez wyłączenie silnika
W momencie wyłączenia auta (przerwania pracy pieca) auto nie odstawia pompki paliwa od Webasto.
Nadal pompuje paliwo do pieca, po kilku chwilach piec gaśnie i robi przedmuch robi sie zadyma oczywiście.

Nie da sie też wystartować pieca z zegara po uprzednim zakodowaniu jako ogrzewanie postojowe. BC przyjmuje timer zapala sie dioda czerwona i w momencie startu nic sie nie dzieje. Nie da sie tez włączyć pieca za jego pomocą.

Co zostało zrobione:
Kilka piecy i elektronik - piec w pełni sprawny
Kodowanie na rożne sposoby
Podmiana licznika i panelu klimatronika
Podanie stałych plusów na piec licznik i klimatronik

Komunikacja z piecem prze OBD bez kluczyka w pełni możliwa

Jakieś pomysły czemu po przekręceniu kluczyka w innej pozycji niż zapłon webasto łapie błąd lini K??

Avatar użytkownika
Harnaś

Imię: Krystian
Posty: 2709
Dołączył(a): 2008-12-07, 10:30
Lokalizacja: WPN/WD

Moje BMW: e60 ///M57TU
e39 m51d25->m57d30
http://bmw5er.pl/viewtopic.php?f=33&t=51750
http://bmw5er.pl/viewtopic.php?f=36&t=76402

Re: [e39] 525d 2001 Webasto K-bus Breakdown

Postprzez Harnaś » 2019-03-20, 10:48

Tytan55 napisał(a):Witam

Tematów wiele jest ale takiego jak mój problem nigdzie nie znalazłem

W skrócie piec przechodzi pełny cykl jako dogrzewacz jeśli auto pracuje i nie przerwie się jego pracy poprzez wyłączenie silnika
W momencie wyłączenia auta (przerwania pracy pieca) auto nie odstawia pompki paliwa od Webasto.
Nadal pompuje paliwo do pieca, po kilku chwilach piec gaśnie i robi przedmuch robi sie zadyma oczywiście.

Nie da sie też wystartować pieca z zegara po uprzednim zakodowaniu jako ogrzewanie postojowe. BC przyjmuje timer zapala sie dioda czerwona i w momencie startu nic sie nie dzieje. Nie da sie tez włączyć pieca za jego pomocą.

Co zostało zrobione:
Kilka piecy i elektronik - piec w pełni sprawny
Kodowanie na rożne sposoby
Podmiana licznika i panelu klimatronika
Podanie stałych plusów na piec licznik i klimatronik

Komunikacja z piecem prze OBD bez kluczyka w pełni możliwa

Jakieś pomysły czemu po przekręceniu kluczyka w innej pozycji niż zapłon webasto łapie błąd lini K??
Sprawdz gdzie jest podlaczona :) i ogolnie ciaglosc tego kabla, moze zasilanie pomieszane? Nie pamietam jak webasto jest podlaczane

Wysłane z mojego SM-G950F przy użyciu Tapatalka
Przyjaciel Degustatora trunku Harnaś w puszce.

Timeless Ultimate Driving Machine
Obrazek

INPA/ISTA/Skalowanie zegarów e6X/e7X/e8X/e9X czasem i pixele ;)

Tytan55

Posty: 17
Dołączył(a): 2011-01-25, 15:30
Lokalizacja: Gdynia

Moje BMW: E39 525d i 530da

Re: [e39] 525d 2001 Webasto K-bus Breakdown

Postprzez Tytan55 » 2019-03-20, 10:53

Co masz na mysli przez pomieszane zasilanie?
Pompkę da się inpą włączyć (test) , da się także uruchomić cykl pieca z poziomu OBD i pracuje też do końca jak auto chodzi i nie przerwie się jego pracy.

Avatar użytkownika
Harnaś

Imię: Krystian
Posty: 2709
Dołączył(a): 2008-12-07, 10:30
Lokalizacja: WPN/WD

Moje BMW: e60 ///M57TU
e39 m51d25->m57d30
http://bmw5er.pl/viewtopic.php?f=33&t=51750
http://bmw5er.pl/viewtopic.php?f=36&t=76402

Re: [e39] 525d 2001 Webasto K-bus Breakdown

Postprzez Harnaś » 2019-03-20, 10:56

Pomieszanie stslego plusa z tym po stacyjce :)

Wysłane z mojego SM-G950F przy użyciu Tapatalka
Przyjaciel Degustatora trunku Harnaś w puszce.

Timeless Ultimate Driving Machine
Obrazek

INPA/ISTA/Skalowanie zegarów e6X/e7X/e8X/e9X czasem i pixele ;)

Tytan55

Posty: 17
Dołączył(a): 2011-01-25, 15:30
Lokalizacja: Gdynia

Moje BMW: E39 525d i 530da

Re: [e39] 525d 2001 Webasto K-bus Breakdown

Postprzez Tytan55 » 2019-03-20, 11:08

Do kostki stacyjki się dokopałem pomierzyłem
Sa 3 kable jakby stały plus na środku mają kolo 12V w spoczynku
Potem jest 1 czarny na dole (rozruch)
2 na górze zielony fioletowy (pojawia się an nich 12V po przekręceniu kluczyka

Tak bardziej obrazowo twoje podejrzenie możesz opisać :)?

Avatar użytkownika
Harnaś

Imię: Krystian
Posty: 2709
Dołączył(a): 2008-12-07, 10:30
Lokalizacja: WPN/WD

Moje BMW: e60 ///M57TU
e39 m51d25->m57d30
http://bmw5er.pl/viewtopic.php?f=33&t=51750
http://bmw5er.pl/viewtopic.php?f=36&t=76402

Re: [e39] 525d 2001 Webasto K-bus Breakdown

Postprzez Harnaś » 2019-03-20, 11:10

Zastanawiam sie po prostu czy ktorys staly plus, jesli jest wiecej niz 2 jest podlaczony do stalego zamiast do stacyjki :)

Wysłane z mojego SM-G950F przy użyciu Tapatalka
Przyjaciel Degustatora trunku Harnaś w puszce.

Timeless Ultimate Driving Machine
Obrazek

INPA/ISTA/Skalowanie zegarów e6X/e7X/e8X/e9X czasem i pixele ;)

Tytan55

Posty: 17
Dołączył(a): 2011-01-25, 15:30
Lokalizacja: Gdynia

Moje BMW: E39 525d i 530da

Re: [e39] 525d 2001 Webasto K-bus Breakdown

Postprzez Tytan55 » 2019-03-20, 12:34

Wynika że są 3 plusy w stacyjce.
20190319_084309.jpg
Co do stałego do WEBASTO był podany z aku.

Avatar użytkownika
Harnaś

Imię: Krystian
Posty: 2709
Dołączył(a): 2008-12-07, 10:30
Lokalizacja: WPN/WD

Moje BMW: e60 ///M57TU
e39 m51d25->m57d30
http://bmw5er.pl/viewtopic.php?f=33&t=51750
http://bmw5er.pl/viewtopic.php?f=36&t=76402

Re: [e39] 525d 2001 Webasto K-bus Breakdown

Postprzez Harnaś » 2019-03-22, 19:41

Patrzac po googlach zazwyczaj konczyl sie temat tym ze sterownik jednak byl winny..

Wysłane z mojego SM-G950F przy użyciu Tapatalka
Przyjaciel Degustatora trunku Harnaś w puszce.

Timeless Ultimate Driving Machine
Obrazek

INPA/ISTA/Skalowanie zegarów e6X/e7X/e8X/e9X czasem i pixele ;)

Tytan55

Posty: 17
Dołączył(a): 2011-01-25, 15:30
Lokalizacja: Gdynia

Moje BMW: E39 525d i 530da

Re: [e39] 525d 2001 Webasto K-bus Breakdown

Postprzez Tytan55 » 2019-03-25, 14:35

Tak bylo chyba przeorałem każdy temat na polskich stronach i jakieś na zagranicznych ale kurcze tu były już 3 elektroniki u mnie :(

Tytan55

Posty: 17
Dołączył(a): 2011-01-25, 15:30
Lokalizacja: Gdynia

Moje BMW: E39 525d i 530da

Re: [e39] 525d 2001 Webasto K-bus Breakdown

Postprzez Tytan55 » 2019-04-02, 08:22

Po kolejnych próbach elektrycznych i próbie zrozumienia działania webasta e39 znów punkt zero
Nie da się pieca wzbudzić pinem 1 podając mu 12v co już jest nieco dziwne
Przekodowałem ZUHIEZR na konventionell na próbe też nic
Czy ktoś może wie jak odbywa się dokładnie komunikacja między IKE - IHKA i piecem?
W WDS jest opisane tylko co do czego wysyła telegramy ale nigdzie nie ma opisu ktory kabelek za co odpowiada
Nie da się też wybudzić samego nadmuchu w kabinie klimatronikiem bez jednoczesnego uruchomienia liczników więc tym samym założyć anlogowej elektroniki która też posiadam.

Avatar użytkownika
Harnaś

Imię: Krystian
Posty: 2709
Dołączył(a): 2008-12-07, 10:30
Lokalizacja: WPN/WD

Moje BMW: e60 ///M57TU
e39 m51d25->m57d30
http://bmw5er.pl/viewtopic.php?f=33&t=51750
http://bmw5er.pl/viewtopic.php?f=36&t=76402

Re: [e39] 525d 2001 Webasto K-bus Breakdown

Postprzez Harnaś » 2019-04-02, 08:51

Po i lub k bus nie pamietam bialo czerw lub bialo szary z zoltymi kropkami

Wysłane z mojego SM-G950F przy użyciu Tapatalka
Przyjaciel Degustatora trunku Harnaś w puszce.

Timeless Ultimate Driving Machine
Obrazek

INPA/ISTA/Skalowanie zegarów e6X/e7X/e8X/e9X czasem i pixele ;)

Tytan55

Posty: 17
Dołączył(a): 2011-01-25, 15:30
Lokalizacja: Gdynia

Moje BMW: E39 525d i 530da

Re: [e39] 525d 2001 Webasto K-bus Breakdown

Postprzez Tytan55 » 2019-04-02, 12:51

Tak komunikacja odbywa się po lini K ale mnie w pierwszej kolejność zastanawia że po podaniu 12V na pin 1szy piec się nie uruchamia.
I pewnie to jest kluczem do tej zagadki
Były podpięte 2 piece i żaden nie ruszył po podaniu 12v

Także tu było by bardzo pomocne coś takiego że kabel ten i tan z pieca idzie do pinu takiego w kostce klimatronika itd

sash997

Posty: 125
Dołączył(a): 2013-12-17, 20:00
Ostrzeżenia: 1

Moje BMW: E39 520d

Re: [e39] 525d 2001 Webasto K-bus Breakdown

Postprzez sash997 » 2019-04-14, 19:16

jeśli masz piec przekodowany na konwentionel i nie odpala po podaniu +12 na 1 pin tzn że albo sterownik na piecu jest zrypany albo dostaje zakłucenia po k-bus na pinie 2, innej możliwości niema, możesz to sprawdzić odłączając pin 2 na piecu (k-bus) przewód biały z czerwonym paskiem

Tytan55

Posty: 17
Dołączył(a): 2011-01-25, 15:30
Lokalizacja: Gdynia

Moje BMW: E39 525d i 530da

Re: [e39] 525d 2001 Webasto K-bus Breakdown

Postprzez Tytan55 » 2019-04-17, 19:09

Już problem ogarnięty. Generalnie wiem już chyba wszystko na temat działania webasto i komunikacji jaka sie odbywa w jego temacie w aucie :D

Winny był odcięty z niewiadomego powodu przewód stałego plusa paneli klimatronika w kablu 3 pinowym. Nie można było połączyć się z kliamatronikiem gdy auto było bez kluczyka.
Przy okazji dołożyłem telestart i wszystko śmiga :D


Powrót do strony głównej

Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 3 gości